以下属于“python 标签”的內容

  • python安装feedparser +2

    python安装feedparser

    2014-09-20 By  分类:Linux 5,022人浏览

    使用python解析rss非feedparse莫属了。feedparse是第三方的python库,需要先安装一下 # wget https://pypi.python.org/packages/source/f/feedparser/feedparser-5.1.3.tar.gz#md5=f2253de78085a1d5738f626fcc1d8f71 --no-check-certificate --2014-09-18 09:22:44-- https://pypi.python.org/packages/source/f/feedparser/feedparser-5....

  • python安装setuptools +1

    python安装setuptools

    2014-09-19 By  分类:Linux 7,136人浏览

    Python中当需要安装第三方python包时,可能会用到easy_install命令。easy_install是由PEAK(Python Enterprise Application Kit)开发的setuptools包里带的一个命令,所以使用easy_install实际上是在调用setuptools来完成安装模块的工作。 为了方便后续安装各种第三方python包,需要先安装setuptools。 安装setuptools的话,下面一条简单的命令...

  • Python中为feedparser设置超时时间 抢沙发

    Python中为feedparser设置超时时间

    2014-09-18 By  分类:Linux 954人浏览

    python有一个用于解析feed的模块:feedparser,feedparser解析各种feed是非常方便的,唯一比较恼火的是遇到一些badurl,经常会导致堵塞,因此需要为feedparser设置一个超时时间。 可是feedparser并没有提供这个功能,只好采用其他方法了,具体办法请参看feedparser项目的issue221。 其实也很简单,按照上面文档的说明 developers have had th...

  • +1

    web开发时如何在PHP、Ruby on Rails和Python中做出选择

    2014-09-14 By  分类:编程语言 2,055人浏览

    开发者在开发web应用时,往往会对平台的选择感到困惑,而web专家通常会建议:要考虑几个因素,这些因素包括周转时间、质量、跨浏览器兼容性、与其他框架的整合、数据安全性、易于访问性等。 在考虑了这些因素后,开发者就会开始纠结于Ruby on Rails、PHP和Python。这三种平台都比较符合以上因素,可以根据项目的需求进行选择。Python和Ruby应...

  • +1

    关于PHP、Python与Ruby

    2014-09-13 By  分类:编程语言 1,233人浏览

    一句话总结 简单地总结: 假如你想帮他尽快找个活儿,赚到钱,推荐PHP。 假如你想让他成为一个高效工程师,推荐 Python。 假如你想让他爱上他的工作,推荐 Ruby。 语言的选择 编程语言非常重要,不要认为他们都图灵等价,用起来都一样。实际上,好的语言,带给你的东西是超乎想像的。 下面是一些看法: 程序员的时间远比机器的时间宝贵:...

  • Python 2.7.3安装bz2扩展 +2

    Python 2.7.3安装bz2扩展

    2014-06-06 By  分类:Linux 3,184人浏览

    在CentOS系统中安装Node.js,遇到如下错误 ImportError: No module named bz2: File "/disk/src/node-v0.6.12/deps/v8/SConstruct", line 37: import js2c, utils File "/disk/src/node-v0.6.12/deps/v8/tools/js2c.py", line 36: import bz2 Waf: Leaving directory `/disk/src/node-v0.6.12/out' Build failed: -> ...

  • CentOS系统升级Python到2.7.3 抢沙发

    CentOS系统升级Python到2.7.3

    2014-06-05 By  分类:Linux 1,228人浏览

    CentOS 系统自带的Python版本是2.4.3,但是目前许多基于Python的应用软件要求的Python版本都需要高于2.4,例如iotop、node.js等要求Python版本至少是2.6以上。 下面开始编译安装Python 2.7.3版本 wget -c http://www.python.org/ftp/python/2.7.3/Python-2.7.3.tar.bz2 --no-check-certificate tar jxvf Python-2.7.3.tar.bz2 cd Python-2...